433MHz Gateway mit dem Raspi

WOLFGANG
Beiträge: 24
Registriert: Sa 19. Mai 2018, 20:27
Wohnort: Linker Niederrhein
x 1

433MHz Gateway mit dem Raspi

Ungelesener Beitrag von WOLFGANG » Fr 25. Mai 2018, 16:39

Ich will mal versuchen etwas Leben in die Bude zu bringen. Mich interessiert es aber auch. :D

Brematic und den Vorgänger Connair kennen die meisten ja. Ist nun wieder eine Hardware die man benötigt, wenn man den einen oder anderen Funk-Schalter schalten möchte.
Die Raspberry kann es aber auch und zwar mit einem recht billigem Sender. Den kann man einfach mit 3 Strippen an dem Raspie anstecken und fertig ist die Laube. Nicht alle haben das Geld für ein Gateway, oder wollen sich nicht, so wie ich, eine Hardware dabei stellen. Bei mir blinkt es überall wie auf der Enterprise, so meine Frau. :) Die Raspi klappt mit dem kleinem Sender sehr gut, aber wie es im Leben so ist, klappen nicht alle Funk-Schalter damit.
Jetzt würde ich gerne mal darüber schwafeln warum meine Connair.py nicht klappt, bzw. es wird nichts geschaltet.

Hier mal die conair.py die in home/pi eingesetzt wird.

Code: Alles auswählen

#!/usr/bin/env python2.7

import socket
import RPi.GPIO as GPIO
import time

UDP_IP = "0.0.0.0"
GPIO_PIN = 16 # GPIO4
UDP_PORT = 49880
HELLO_MESSAGE = "HCGW:VC:dede53;MC:ConnAir;FW:1.00;IP:192.168.2.124;;"

GPIO.setmode(GPIO.BOARD)
GPIO.setup(GPIO_PIN, GPIO.OUT)

sock = socket.socket(socket.AF_INET, socket.SOCK_DGRAM) # UDP
sock.bind((UDP_IP, UDP_PORT))

while True:
    data, addr = sock.recvfrom(1024) # buffer size is 1024 bytes
    # "TXP:0,0,6,5950,350,25,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,3,1,1,3,1,3,1,3,3,1,1,17;"

    print "received message:", data, "from ", addr

    msg = str(data).split(":")

    if msg[0] == "SEARCH HCGW":
        sock.sendto(HELLO_MESSAGE, addr)
        print "Hello message"

    if msg[0] == "TXP":
        msg[1] = msg[1].replace(";", "")
        cmd = msg[1].split(",")
        rep = int(cmd[2])
        pauselen = int(cmd[3])
        steplen = int(cmd[4])
        numpulse = int(cmd[5])
        pulsedata = cmd[6:]

        arrayreader = 0
        i = 0
        while i < rep:
            while int(arrayreader) < (numpulse * 2):
                GPIO.output(GPIO_PIN, True)
                # print pulsedata[arrayreader], "an"
                time.sleep((int(pulsedata[arrayreader]) * steplen ) / 1000000)
                arrayreader += 1

                # print pulsedata[arrayreader], "aus"
                GPIO.output(GPIO_PIN, False)
                time.sleep((int(pulsedata[arrayreader]) * steplen ) / 1000000)
                arrayreader += 1
            i += 1
Damit muß man umbennen, von conneir.txt in connair.py.
Aufruf via Putty mit sudo python connair.py
Dann wird mit Auto-Detect Gateway das Gateway gefunden.

In der ursprünglichen connair.py war in Zeile 8 "GPIO_PIN = 4 # GPIO4"
Ich denke mal das kann so nicht stimmen da der GPIO_Pin eine 16 ist.


Wo bin ich da falsch abgebogen?
Dateianhänge
connair.txt
(1.52 KiB) 20-mal heruntergeladen
Zuletzt geändert von WOLFGANG am Fr 25. Mai 2018, 21:08, insgesamt 1-mal geändert.
0 x
Gruß
Wolfgang

onkeldave
Beiträge: 76
Registriert: Mi 16. Mai 2018, 07:01
Wohnort: Bei HH
x 22

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von onkeldave » Fr 25. Mai 2018, 20:24

Worum gehts denn eigentlich genau? Meinst du dies hier?
https://github.com/Phunkafizer/RaspyRFM
0 x

Benutzeravatar
mrberni
Administrator
Beiträge: 117
Registriert: Di 15. Mai 2018, 17:25
Wohnort: City 17
x 26
Kontaktdaten:

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von mrberni » Fr 25. Mai 2018, 20:53

Stimmt denn die Pin-Nummerierung überein? Bei den ESPs gibts da ja auch Unterschiede in der "zählweise"...

Gruß
0 x
We Do What We Must, Because We Can.

WOLFGANG
Beiträge: 24
Registriert: Sa 19. Mai 2018, 20:27
Wohnort: Linker Niederrhein
x 1

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von WOLFGANG » Fr 25. Mai 2018, 21:00

Die connair.py habe ich natürlich vom "kleinen Mann"

Mit der Zählweise komm ich ja nicht ganz klar. GPIO_PIN = 4 # GPIO4 ist auf jedem Fall falsch, da kommt eine Fehlermeldung. "The channel sent is invalid on a Raspberry Pi"


Wie kann ich die connair.py beim Start der Raspi einbinden. Ich kann ja nicht dauernd mit Putty hinterher tippern.
0 x
Gruß
Wolfgang

Benutzeravatar
mrberni
Administrator
Beiträge: 117
Registriert: Di 15. Mai 2018, 17:25
Wohnort: City 17
x 26
Kontaktdaten:

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von mrberni » Fr 25. Mai 2018, 21:18

WOLFGANG hat geschrieben:
Fr 25. Mai 2018, 21:00
Die connair.py habe ich natürlich vom "kleinen Mann"

Mit der Zählweise komm ich ja nicht ganz klar. GPIO_PIN = 4 # GPIO4 ist auf jedem Fall falsch, da kommt eine Fehlermeldung. "The channel sent is invalid on a Raspberry Pi"

Wie kann ich die connair.py beim Start der Raspi einbinden. Ich kann ja nicht dauernd mit Putty hinterher tippern.
Zu dem Autostart: Das sollte dir eventuell weiterhelfen können:
https://www.tecchannel.de/a/cron-linux- ... en,3205434

Zu den Pins: Schon mal hier geguckt?
https://www.raspberrypi.org/documentati ... /README.md

Gruß
0 x
We Do What We Must, Because We Can.

WOLFGANG
Beiträge: 24
Registriert: Sa 19. Mai 2018, 20:27
Wohnort: Linker Niederrhein
x 1

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von WOLFGANG » Fr 25. Mai 2018, 21:26

Ja Danke für den Anstiß, da war doch mal was mit cronjob. :o

Ich hab ein Bildchen von der Raspi und den Pins

Bild
Dateianhänge
GpioPort.png
0 x
Gruß
Wolfgang

Benutzeravatar
mrberni
Administrator
Beiträge: 117
Registriert: Di 15. Mai 2018, 17:25
Wohnort: City 17
x 26
Kontaktdaten:

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von mrberni » Fr 25. Mai 2018, 21:33

Und das Bild passt nicht? Bzw. das funktioniert dann nicht? Was hast du denn genau für ein Modell?

Gruß
0 x
We Do What We Must, Because We Can.

WOLFGANG
Beiträge: 24
Registriert: Sa 19. Mai 2018, 20:27
Wohnort: Linker Niederrhein
x 1

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von WOLFGANG » Fr 25. Mai 2018, 21:45

Das letzte Modell.

Das Bild passt schon, aber die in der connair.py vorgesehene "GPIO_PIN = 4 # GPIO4" kannnicht stimmen. Hab ich also umgeändert in GPIO_PIN = 16 # GPIO4

Dann wird auch ein Gateway gefunden, aber nichts geschaltet.


Nach Abbruch mit Strg + C kommt allerdings eine Meldung : Line 19 "data, addr = sock.recvfrom(1024) # buffer size is 1024 bytes"
0 x
Gruß
Wolfgang

Kleiner Mann
Beiträge: 10
Registriert: Do 17. Mai 2018, 17:39
x 9

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von Kleiner Mann » Fr 25. Mai 2018, 22:41

Wie ich vor ein paar Monaten schon dazu geschrieben hatte:
Ich habe hier keinen Pi und die Software war einfach nur ein Versuch die Softwarefunktion zur Verfügung zu stellen um getestet zu werden.
Da die Funksignale sehr Zeitkritisch sind, war von Anfang an der Gedanke vorhanden, dass es nicht unbedingt mit dem Pi funktioniert.
Wenn du das nun getestet hast und es nicht läuft dann ist der Versuch gescheitert.

Einzig ob deine Installation funktioniert und es tatsächlich das Problem ist oder ob es ein Problem in deinem Aufbau ist kannst du testen indem zu etwas das leuchtet ( z.B. LED/Widerstand )an den Pi, an den Signalausgang anschließt. Diese sollte Blinken wenn du etwas sendest. Ist dies der Fall und mit dem Sender schaltet jedoch nichts ist der Feher auf das Timing-Problem zurück zu führen. Wenn nicht liegt es an deinem Aufbau.

Viel Erfolg!
0 x

WOLFGANG
Beiträge: 24
Registriert: Sa 19. Mai 2018, 20:27
Wohnort: Linker Niederrhein
x 1

Re: 433MHz Gateway mit dem Raspi

Ungelesener Beitrag von WOLFGANG » Sa 26. Mai 2018, 15:36

Hallo Daniel
Schön von dir zu hören.
Dass dies ein Versuch ist oder war, ist doch klar gewesen.
Ich möchte darüber diskutieren, oder besser, das Ding am laufen kriegen.


Ich hoffe du kommst gesund und in einem Stück wieder. Ist eine heiße Gegend.
0 x
Gruß
Wolfgang

Antworten